T-Com (UltraMAX) FTTH with OpenWRT

In our country (Croatia) fiber internet connection became afordable to the home user. For about $50 per month, you will get 100/20 mbit/s DL/UL speed with FLAT bandwidth.

Usually they will ship shitty equipment, like it was in my case. ZTE ZXDSL931VII was meant to be the main router and TP-Link TX-6610 as GPON terminal.

Main disappointment is that ZTE has four 100mbit/s ports ... In real life, when testing with speedtest.net you will get maximum 94mbit/s DL speed instead 100mbits/s (for me it looks like physical limit of an ethernet port on ZTE), so I decided to replace ZTE with dual band TP-Link WR3600 model (which has all 5-ports gigabit). OpenWRT firmware will be installed.

In their FTTH network infrastructure traffic on WAN port is tagged with vlan100 over PPPoE connection.

Download appropriate version of OpenWRT regarding the version of your router. Here you can find compatibility list of all supported devices. Also they have a pretty nice WIKI, where you can find all necessary information.

Flash your device with OpenWRT firmware.

To be able to download and install packages, working internet connection on router is needed. To achieve that, connect WAN port of your device to your local network (ISP router) LAN port, and your PC into the LAN port on OpenWRT device. Log into the router and perform those steps.

opkg update
opkg install ppp kmod-pppoe ppp-mod-pppoe

 

Openwrt configuration should look like this.

vim /etc/config/network
config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd1c:bda7:abdc::/48'

config interface 'lan'
    option ifname 'eth0.1'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ipaddr '192.168.1.1'
    option dns '8.8.8.8'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0t 2 3 4 5'
    option vid '1'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option vid '100'
    option ports '0t 1t'

config interface 'wan'
    option proto 'pppoe'
    option ifname 'eth0.100'
    option username 'username@htnet-dsl'
    option password 'password'

 

Turn OFF the router. Replace your ISP router with OpenWRT device. Turn ON ...

 

And (if everythings goes well) TA-DA you have guranteed 100/20 mbit/s DL/UL speed (in my case 104/25 mbit/s) ;)

Comments

ajde dodaj mi da bude port 4 od lana vid 101 za voip i imas pivu... :)

 

Add new comment

Filtered HTML

  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <em> <strong> <cite> <blockquote> <code> <ul> <ol> <li> <dl> <dt> <dd>
  • Lines and paragraphs break automatically.

Plain text

  • No HTML tags allowed.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Lines and paragraphs break automatically.
CAPTCHA
This question is for testing whether or not you are a human visitor and to prevent automated spam submissions.